User Guide
Sign in
TickTick won't load webpage
I added 2FA to the google account I use to sign into TickTick, and now TickTick won't load in the web page. When I try to view my tick tick home, I just get a blank white page with 3 bullets (same with the chrome extension).

I logged out then logged back in on the site, but no change.
I'm pretty sure it's because TickTick is supposed to prompt google for my 2FA on log-in, but it isn't doing it.

Any fix?
Sorry for the trouble. We have found the issue and will get it fixed asap.
I am having the exact same issue with the 3 bullets. I tried clearing my cache, resetting password, and from IE and Chrome on two different computers. The mobile app still works, but not working from the browser.
I am getting the same error/activity
I am also facing the same issue.
Me too. Just 3 black dots on the left, not loading.
Me too. Just 3 black dots on the left, not loading.
Ok glad to see it's not just me. Im having the same issue. 3 bullets. I hope it gets resolved soon. Still working on android. But not windows
Just 3 black dots for me too...
It works for me now.
I cleared the cache and cookies on Chrome and it worked for me!
Tick Tick has resolved the issue. Thanks dev team!
Why is still not working for me
I'm still getting 3 dots. How exactly are people clearing the cache & cookies in Chrome please? I've tried these:
- in chrome://settings/siteData
- https://www.thewindowsclub.com/clear-cache-cookies-specific-website
- https://support.google.com/accounts/answer/32050?co=GENIE.Platform%3DDesktop&hl=en
- https://support.google.com/chrome/forum/AAAAP1KN0B0YEE24sDJxfo/?hl=en&gpf=d/topic/chrome/YEE24sDJxfo
Down again, the second night.
Not working for me either, I'l try some of these suggestions and see if anything works.
Streij, in Chrome I:
went to the settings menu,
searched for "clear browsing data",
clicked on the search result "clear browsing data",
set the timeframe to "All time",
made sure all three boxes were ticked,
clicked "clear data",
then did a full refresh (ctrl+f5) of my open TickTick tab.
I had to log in again, but it is now working.
Thank you Ben. I used that process before except I didn't clear "All time", and I also tried all cache for ticktick.com. However, I didn't do anything to clear cache since posting out of frustration 2 days ago, and today it is working for me . So I'm suspecting the Developers found a way to fix/clear cache grammatically. I also found Opera browser worked well as a work-around.
While the app has been down for me I have created a link on my home screen that is the Chrome browser, which works fine for accessing Tick Tick as a work-around.
Please  Sign in  to post a topic.

Help | Blog | Upgrade to Premium | Contact | Privacy | Security | Terms | Thanks | License