User Guide
Sign in
Links in tasks stopped working
Until recently, I was able to put links such as the following in task titles and descriptions:


and they would be followed when clicked. Now, they are treated as regular text.

The function should be fine. We tested the url you provided and it seemed like the url itself is not a valid one. Could you try with other url and see if it works?
When Thunderbird is installed with the ThunderLink extension, the registry entries below make thunderlink URLs such as the one above open a linked email message. These previously worked in TIckTick task titles and descriptions, which was *very* useful. A TickTick update broke this feature.


@="URL:thunderlink Protocol"
"URL Protocol"=""



@="\"C:\\Program Files (x86)\\Mozilla Thunderbird\\thunderbird.exe\" -thunderlink \"%1\""
Are you using Chrome or Firefox? If it's Firefox, could you provide your version?
I'n using chrome Version 63.0.3239.108 (Official Build) (64-bit), but I doubt that is related to the problem, since the link launches Thunderbird to open the email message, not a browser. Note that these links work in other apps, such as MS Office and Notepad++.
BTW, docs ( claim that thunderlinks work with other todo list apps:

"With version 1.0.0, It's now also easy to integrate ThunderLink with todo lists and task managers such as RememberTheMilk, MyLifeOrganized, Evernote, OneNote, Nirvana, Taskwarrior, etc."

More info on Asynchronous Pluggable Protocols:
I have also seen links turn to text.
Hello Sean,

Was there also a ThunderLink that you saw?
So is this going to be fixed? If so, when?
We are still working on it. Will try to fix it within the shortest time. Sorry again for the troubles.
Here's a related problem: if I paste this link as a task title:

Your B&H Order #1049165923 Is Confirmed. Thank You!

and hit enter, the task isn't recorded, it's ignored. This is also a recently-introduced bug.
Here's another example of a link that isn't recognized:

When is this going to be fixed?
Here's yet another example of a link that isn't recognized:

Links have been broken for several months. When is this going to be fixed?

Sorry for the late reply. Could you confirm again that the two links could be recognised before? We cannot reproduce it on our side.
I've confirmed that these links are still not recognized:

Fwd: Read today's San Francisco Chronicle e-edition

And also that the following task title:

Your B&H Order #1049165923 Is Confirmed. Thank You!

causes the task to not be recorded.

You're testing these in the Chrome extension, right?

I can send you screen shots if needed.
Another link not recognized:
Note that Thunderlinks, e.g. thunderlink://messageid=1fe0c0a2-35e9-4927-9941-40ac764e0f54@localhost, are not URLs, but are valid URIs -- see
Is there a way to revert to a version of the Chrome extension from about 6 months ago? Every day I encounter more examples of these broken links, a feature that previously worked. In the meantime, no features useful to me have been added. Tick Tick is headed downhill.
Thunderlinks and other links working again! Thanks.
I have a very similar problem but my mail app is Postbox.

An example link is:

It used to work and would pull up the specific email in Postbox. Now it tries to open it in a browser when the x-postbox- part of the link should open it in Postbox. Could you folks please look into this?

Edit: Looks like this is a very old post from almost two years ago, so I will create a new one.
Please  Sign in  to post a topic.

Help | Blog | Upgrade to Premium | Contact | Privacy | Security | Terms | Thanks | License